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Buzan’s iMindMap® Quick Start Guide – Mac Users 

CREATING YOUR FIRST MIND MAP 

 
This guide is designed as a quick starting point for learning how to use iMindMap®. Simply follow the basic step-by-
step instructions to create your first Mind Map.  
 
This guide is not intended as a complete illustration of all the features of iMindMap®. For more information on all 
of the features and advanced tools contained within the software, please explore iMindMap® Help which can be 
accessed from the iMindMap® Main Menu. 
 

Step 1 - Central Idea/Theme 
 
Using a central image to help represent your main goal or theme is a major factor in effective Mind Mapping. It 
automatically focuses both sides of your brain and helps to draw upon all your senses to trigger relevant 
associations.   
 
(1.1) When you open iMindMap®, you will be presented with a window prompting you to select an image to 
surround the central idea/theme of your Mind Map (please see Fig 1 below). 
(1.2) Click on the image that best corresponds to your central theme; then enter the name of your central theme by 
typing it in the text entry box provided underneath the selection of images. Alternatively, click ‘browse’ near the 
top of the window to find a suitable image which you may have on your computer. 
 

 
 

Fig 1 
 
(1.3) Click on ‘Create’ to open up your Mind Map workspace. 



Buzan Online Ltd 

 2 

(1.4) Your central theme will then be displayed in the centre of the screen ready for you to expand on with further 
topics (see Fig 2 below). 
 

 
 

Fig 2 
 
Note: The name that you give your Mind Map will automatically be adopted as the name of the iMindMap® file. 
This has the extension .imm when saved. If you wish to use a different name for your file, go to File > Save As and 
amend your file name.   
 

Note:  Mind Map Mode is defaulted on when iMindMap is launched.  Mind Mapping Mode will 
allow you to create organic free flowing Mind Maps. The steps below, describing creating branches and sub-
branches, are specifically for Mind Mapping Mode.  However, in certain circumstances you may want to work in 

Speed Mind Map Mode which uses a different ‘fast’ approach when creating Mind Maps. See  
SpeedMapping Mode at the end of this guide or the Buzan’s iMindMap V3 Quick Guide on Speed Mind Map Mode 
located at [LINK] for more information.   
 
 

Step 2 – Main Branches (Basic Ordering Ideas) 
 
Now you are ready to add a series of primary ideas connected to your central theme.  
In order to control and apply your mental power, you need to structure your thoughts using hierarchy and 
categorisation. Your main branches represent your Basic Ordering Ideas, the primary concepts or ‘hooks’ on which 
to hang all associated ideas. These will help to shape, sculpt and construct the Mind Map, encouraging your mind 
to think in a naturally structured way.  
 

(2.1) To create a main branch – Left Click over the red circle in the centre of the Central Image (which will 

appear when you hover your mouse pointer over the Central Image) and drag your mouse outwards until your 
achieve the desired branch length. 
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 It is recommended that you select the Organic Branch tool so that you can quickly create pre-
defined, organically shaped branches. The curved branches created by iMindMap® are designed to be more 
interesting to the eye and more memorable to the brain than linear branches.  

 
(2.2) To add a label/text to your branch – Immediately after creating your branch type your text and it will 

then be automatically attached to the branch (see Fig 3 below).  
 
If you wish to edit your text, Double Click on the branch to bring the label/text entry box up again. The type of font 
used and font size is automatically selected by iMindMap® according to pre-determined settings. If you wish to 
alter the font and font size used, you can do so using the drop-down font options in the formatting toolbar.  
 

 
 

Fig 3 

Tip: For effective Mind Mapping, try to only use one keyword per branch. A single word is better at triggering 
thoughts and aiding memory recall than phrases or sentences.  

Now create as many branches as you like to represent your primary concepts. Please see example below (Fig 4). 
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Fig 4 

(2.3) Modifying or moving your branch  

 To modify or move your branches, Left Click and Drag your mouse over the blue ring found on the outside of 
any Branch Target which appears when you point your mouse at the end of any branch. This is ideal for lengthening, 
shortening, raising or lowering branches. 

(2.4) Reshaping your branch 

   To amend the shape of your branches, Left Click and Drag your mouse over the Control Points (blue or 
white circles) that appear inside the length of an existing branch. To add more Control Points, simply hold down the 
shift key and click on the spot on the branch where you want the new Control Point to appear. 

(2.5) Colour of branches 

Using a different colour for each of your main branches is useful for categorizing your ideas.  

If you wish to change the colour of a branch, select the branch by Left Clicking on it and then modify 
the branch colour using the Colour Selector Tool located in the formatting toolbar.  

 

Tip: You don’t need to spend much time formatting your Mind Map at this stage. The key to Mind Mapping is to 
think freely and creatively so as to capture all your main thoughts and associations. You can always reorganize 
and enhance your results later on.  

For future use – AutoMap offers a selection of tools to speed up and customise your Mind Mapping experience 
such as fonts and colours. You can select your preferred settings for these in the Tools> Options > AutoMap menu. 
In addition, the Tools > Options > Appearance menu offers a variety of options for changing the style attributes of 
your Mind Map.  
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Step 3 - Adding Images/Symbols to your Main Ideas 
 
Using images and symbols when creating your main branches will clarify your Mind Map and make it look more 
attractive. Images will assist in prompting your imagination and can aid memory through their ability to trigger 
associations in your mind. In addition, you can use icons or symbols to code the meaning of topics, for example, 
you can mark specific ideas as good or bad, high priority, low priority and so on. 
 

(3.1) Image Library – The Image Library contains over one million images which you can browse for inclusion in 

your Mind Map. To access the Image Library, click on the View menu in the main toolbar, and then select Image 
Library. 
 

 
 
The Image Library will appear on the left-hand side of the screen. 
 

 
 
The Image Library has a built-in search tool which requires you to type a word or phrase into the search bar and 
click on the category of image you wish to search in – clipart, 3D stills, animations or photo objects. You can also 
select the number of results that you would like to show on each page. Once this is done, click ‘Search’. 
 
You will then be presented with a choice of images related to your search word or phrase. If there is more than one 
page of images, click on the ‘Next’ arrow to view more. 
 

(3.2) Icon Library – The Icon Library contains a diverse bank of icons which can be used in your Mind Map.  The 

icons are classified into categories for easy navigation. To access the Icon Library, click on the View menu in the 
main toolbar, and then select Icon Library. The Icon Library will appear on the left hand side of the screen. 
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Click on the icon you wish to use by double clicking on it or selecting it and then clicking ‘Insert’.  
 
 
(3.3) Inserting an image from the Image and Icon Libraries –  

 Inserting on to a branch – To attah the image or icon to a branch, you must first make the branch active 
before using the Image / Icon Library. Select ‘Insert’ once you have chosen your required image (please 
see Fig 5 below).   

 Inserting as a floating image – To insert the image / icon as a floating image which you will be able to 
move anywhere on your Mind Map, ensure that no branches are selected, choose your required image 
and press ‘Insert’. Your image will now be visible on the iMindMap® workspace. 
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Fig 5 
 

(3.4) Re-positioning an image / icon - Your image or icon, both when placed on a branch or free floating, can be 

clicked and dragged to any other position on your Mind Map.   
 
Now position your image/s or icon/s in their appropriate places. An example is shown below (Fig 6). 
 

  
 

Fig 6 
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(3.5) Re-sizing an image / icon – To re-size an image / icon, Left Click on the image / icon, then click and drag on 

any of the eight ‘Grab Handles’ that appear. 
 

 
 

(3.6) Rotating an image - To rotate an image click and drag on the rotation tool which appears in the bottom 

right hand corner of the selected image. Please note animations cannot be rotated. 

 
(3.7) Inserting images from external files – If you wish to include an image that you have saved elsewhere in 

an external application, you can easily attach it to your Mind Map. 
 

  To attach an image to the active branch select the branch you want to attach the 
image to. You can access your own picture files on your computer by either clicking the Insert Menu on 
the main toolbar and selecting Branch Image. 

  To attach a floating image ensure that no branches have been selected. Either click 
the Insert Menu on the main toolback and select Floating Image.   

Step 4 – Creating Child Branches (Secondary and Tertiary Ideas) 
 
Now that your main branches are in place, your secondary and tertiary concepts can flow quickly and easily to 
facilitate a harmonious thought structure. 
 

(4.1) Adding child branches 
 

 You can create child branches from your existing main branches by clicking and dragging from the red centre 
circle of a branch target that will appear when you point towards the end of a branch. iMindMap® will 
automatically create thinner branches to characterise this next level of ideas and associations (see Fig 7 below). It is 
recommended that you: 
 

 Use key words to develop and explain your main ideas. 

 Again try and only use one word on each of your branches to help your mind spark off new ideas and 
thoughts – keep it simple. 

 Keep exploring all of your main branches until you feel that you have added enough child branches to 
reflect all your next level of associations.  
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Fig 7 

 You can delve into your subject further by adding more sub-branches to your child branches to represent 
your tertiary thoughts and concepts and so on. 

 Remember to include images and symbols where appropriate to engage your imagination, clarify topics 
and aid your memory. 

(4.2) Expanding and Collapsing Branches 

All branches that are created with child branches will display an expand (+) or collapse symbol (-) on them. Click 
these symbols to make your child branches appear or disappear. This feature maximises your workspace and allows 
you to show small parts of your map at any given time– ideal for presentations and keeping your audience focused. 
 

 Click the (-) sign to collapse the child branches             

 Click the (+) sign to expand the child branches            
 

 

Step 5 – Emphasising Relationships and Highlighting Topics 

(5.1) Adding Relationship Arrows 

A Mind Map presents a hierarchical layout for conveying ideas and topics, however, there may be times when two 
concepts are related to each other even if one does not follow the other. To make connections within and across 
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the branch pattern, you can use the Relationship Arrow feature in iMindMap®. Arrows automatically guide your 
eye to connect one part of a Mind Map with another. To add Relationship Arrows: 

  Firstly select the Draw menu on the main toolbar and then select Arrow.  

 Select the end of one of the branches that you wish to connect with another and then click and drag to the 
related branch. 

 When you release the mouse, your relationship arrow will appear connecting the two ideas. 

 To modify the shape of the arrow, simply click and drag your mouse over the Control Points (blue or white 
circles) that appear inside the length of the arrow. You can add more control points to make them more 
flexible by holding down the shift key and clicking on the spot where you want the new control point to 
appear. 

  To change the colour of your arrow, ensure the arrow is selected and modify the colour using the 
Colour Selector Tool. 

 Once you have drawn your arrow, the Draw tool will automatically default back to the mode it was in 
originally (Organic or Freehand). 

 

Fig 8 

You can also format relationship arrows by highlighting the arrow and going to the Format menu.  Here you can opt 
for solid, dashed or dotted arrows as well as single or double arrow heads. 
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If you want to give your relationship arrow a bit of an explaination, you can add text to it by double clicking on it 
and inputting the text into the box that pops up. When you hit enter, the text will appear on the arrow.  

(5.2) Highlighting topics (Adding Clouds) 

Adding highlights in the form of clouds or other shapes can make specific topics ‘stand out’ making them easier to 
remember and communicate to others. iMindMap® enables you to add a Cloud to a specific topic so that important 
elements in your Mind Map can be emphasized. To add a Cloud: 

 Ensure the branch topic that you want to add a Cloud to is selected. 

 On the Insert Menu, select Cloud > New Cloud. A Cloud will now surround your selected topic. Please see 
Fig 9 below. 

  

Fig 9 

 If you want to amend the colours and shape of your Cloud, select Cloud > Cloud Settings from the Edit 
Menu. You can also access the Cloud Settings by double-clicking anywhere on the cloud (Fig 10). This will 
give you options to select fill and line colours and to define a custom shape for your Cloud. To define the 
shape, ensure that the tick box beside ‘Define custom shape for this cloud’ is selected. This will now allow 
you to drag through three different scales which control the size of the Cloud, its bend proportion and its 
bend spacing. Make sure the branch that the Cloud is associated to is selected in order to make the 
options available.  

  

Fig 10 
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 To remove your Cloud, either in its entirety or just from a specific branch, go to Edit > Cloud and select 
either ‘Remove Cloud from Branch’ or ‘Remove Entire Cloud’. 

Step 6 – Inserting & Moving Branches 

Once you have created branches you can easily insert new or existing branches. 

(6.1) Inserting branches 

Inserting Branches  

As well as drawing branches, you can insert branches for three different purposes. 

Inserting New Branches:  You can insert a new branch after an active branch by going to the Insert menu.  Next 
choose Branch and then New.  This will insert a brand new branch for you quickly.  This is ideal if you are 
brainstorming or want to make additions to your Mind Map quickly. 

 

Keyboard shortcut is also available: 

Cmd+ I  Inserts a new branch after the active branch 

You can also use the Insert Branch tool to insert new branches between an existing parent and child branch. 

Please note that following instructions are not recommended as a means of drawing new branches.  

Inserting Branches After an Active Branch: To insert a new branch after an active branch, you first need to make the 
branch active and then select Insert > Branch, from the Main Menu.   

 

Inserting Branches After an Before Branch:  To insert a new branch before an active branch, you first need to make 
the branch active and then select Insert > Branch, from the Main Menu .   

 

Keyboard shortcuts are also available: 
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Cmd+Shift+I Inserts a branch AFTER the active branch 

Cmd+Alt+I Inserts a branch BEFORE the active branch 

Note: To draw a new branch click and drag from the red centre circle of the branch target which is located at the 
end of a branch.  Insert Branch is not recommended for creating new branches.  

 (6.2) Moving branches to new positions 

To move branches to new positions select the branch you wish to move and whilst holding the left mouse button 

down drag to the desired branch.  When the cursor changes to a + when directly over the branch, release the 

mouse.  The branch and its child branches will then be inserted. 

Please note: when moving branches or cut and pasting branches iMindMap will automatically flip the branches so 
that they continue to have the same structure but they also follow the correct direction of their new parent branch. 

Step 7 – Background Colour Scheme 

(7.1) Adding a background colour to your Mind Map 

Adding a background colour can enliven the entire look and feel of your Mind Map, making it more attractive. 
Remember, use of colour stimulates your memory and creativity.  To add a background colour: 

  On the Tools > Options > Appearance tab, go to ‘Background Colour’ and select a colour using the 
Colour Selector Tool. Click ‘OK’. 

  

 Your Mind Map will now include your chosen background colour scheme. See Fig 11 below. 
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Fig 11 

Step 8 – Attaching Information 

To further explain and explore specific concepts, you may wish to link files, hyperlinks or notes to some of your 
branches. These can be accessed for reference purposes at any time. 

 
(8.1) Attaching files and links 

  To attach a link to a branch, ensure the branch you want the link to appear on is selected, then click 
on the Insert menu on the main toolbar and then select Link. A branch editor box pops up with the Link tab active. 
To add a file to the branch, click the Add Files button. A dialogue box will pop up to allow you to browse your files 
and select the one you want to link to. To add a link to the branch, click the Add Link button. Input the URL or file 
location in the text box and then click OK. 

This icon  will be displayed against a branch which has a link or file attached. You can access the links or files 
attached by clicking on the icon. 

(8.2) Adding Text Notes 

You may want to assign a comment or note to a topic without it being immediately visible on your map so as to 
avoid clutter. Use the ‘Notes Editor’ for this: 

  Notes Editor – iMindMap® includes a word processor that will allow you to add notes to your 
branches. Ensure the branch you want to attach the note to is selected. Then, simply click on the Insert menu in the 
main toolbar and select Notes.. A dialogue box will open up for you to enter your notes. For a description of all of 
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the tool buttons available within the Notes Editor, open the Notes Editor and hover your mouse over each button 
to display its tool tip.  

 

Activate the note by clicking ‘Save’. Branches with notes attached will display this icon:   

When you hover your mouse over the note icon, a pop up will appear to show what your note says.  

Step 9 – Exporting your Mind Map 

There are several export options within iMindMap®, giving you choice in how you want to share and transport your 
Mind Map.  These include: 

 Exporting as an image file. 

 Exporting to an SVG  

 Exporting to PDF 

 Exporting as a Web Page 

 Export as a Text Document 

 Export as a Spreadsheet 

 Export as a Presentation and Interactive Presentation 

 Export to Microsoft Project  

The Export Menu can be accessed by clicking the drop-down menu within the Save menu (click on the arrow) and 
then selecting Export. From there, the list of export option will appear for you to select. Alternatively, you can 
access the Export Menu by clicking File > Export > and selecting what format you want to export your Mind Map to. 

 (9.1) Exporting as an Image 

 You can export a copy of your Mind Map as an image file by selecting Image from the Export Menu. 
Choose where to save your image file on your machine and select which format you would like to export your 
image in. You can choose from the following: Bitmap (*.bmp), Jpeg (*.jpg) and PNG (*.png). 
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You will be requested to select the required quality of the image to be exported: 

 

(9.2) Exporting to an SVG file  

 Ideal for large, high quality printing tasks, you can export a copy of your Mind Map to a Scalable 
Vector Image file by selecting SVG from the Export Menu. Choose where to save your image file on your machine. 

You will be requested to select the required quality of the SVG image to be exported: 

 

 

(9.3) Exporting to PDF 

 You can export a copy of your Mind Map as a PDF document file by selecting PDF from the Export 
Menu. You will be asked to select the location in which to save your PDF file. 
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An image of your Mind Map will be displayed on the first page of your PDF document. 

(9.4) Export As Web Page  

 You can export your Mind Map as a Web Page. This option can be found by selecting Web Page 
from the Export Menu.  You will then be requested to select the size of your exported Mind Map and a file location. 
See below: 

 

Any animations will be exported as animated gifs.  

(9.5) Export as a Text Document 

 Export your Mind Map as a text document in Microsoft Word or OpenOffice by selecting Text 
Document from the Export Menu. Select which format you want to export your document in: OpenOffice or Word. 
If you select Word, choose whether you want it to be exported in Word 97-2003 or Word 2007 versions. Now 
choose your document’s orientation: landscape or portrait. Also, if you want to export and tables or if you want the 
document to open immediately after exporting, select the options beside their tick boxes. Now, choose a file 
location for your exported Mind Map and click Export. See below: 



Buzan Online Ltd 

 18 

 

This export saves the Text Documents as a .doc file.  This file can then be opened in any program that supports .doc 
files; for example Text Editor or Pages.  Just follow the same process above [it does not matter what Format you 
select - Word or OpenOffice].  Then when in your text program such as Text Editor simply browse for your .doc file 
and it will open successfully.  

 

(9.6) Export as a Spreadsheet 

 Export to Spreadsheet allows you to export numerical based Mind Maps into Microsoft Excel or 
OpenOffice Calc.  This is ideal for budgets, financial projections, costing and sales reports.  Export your Mind Map 
as a spreadsheet in Microsoft Excel or OpenOffice by selecting Spreadsheet from the Export Menu. 
 
Select which format (OpenOffice or Excel) you want to export your Mind Map to. Then choose what type of layout 
you would like your spreadsheet to have: Flat or Nested. Choose a location where you want to save your exported 
spreadsheet to by clicking Browse and then Export. 
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This export saves the data as a .xls file.  This file can then be opened in any program that supports .xls files; for 
example Numbers or Calc.  Just follow the same process above [it does not matter what Format you select - Word 
or OpenOffice].  Then when in your presentation program such as Numbers, simply browse for your .xls file and it 
will open successfully.  

 

(9.7) Export as a Presentation 

 You can export your Mind Map as a presentation by selecting Presentation in the Export menu. A 
dialogue box pops up where you can choose your settings for your presentation. Select your format in either 
OpenOffice or PowerPoint. Choose how you would like your presentation to look with the Introduction, Transitions, 
Conclusions and Extras settings. Click the Browse button to choose a location for your presentation file, then click 
Export. 

 

This export saves the Presentations as a .ppt file.  This file can then be opened in any program that supports .ppt 
files; for example Keynote.  Just follow the same process above [it does not matter what Format you select - Word 
or OpenOffice].  Then when in your presentation program such as  Keynote simply browse for your .ppt file and it 
will open successfully.  

(9.8) Export as Project 

You can export your Mind Map to Microsoft Project if you have used iMindMap® in Project Management mode 
(Ultimate Edition only). To export to Project, ensure you are currently in Project Management mode by selecting 
Project Management under the Mode menu located in the main toolbar. Select Project under the Export Menu. A 
dialogue box will pop up where you can give your file a name and a location. iMindMap® will save your file *.mpx 
file where you can open it and amend it in Microsoft Project. 

This export saves the data in as a .mpp file.  This file can then be opened in any program that supports .mmp 
files.  Just follow the same process above and then when in your presentation program simply browse for your .ppt 
file and it will open successfully.  
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Step 10 – Printing, Saving and Importing your Mind Map 
 
(10.1) Printing 

 You can print your active Mind Map by selecting the print tool located on the main toolbar. You can also 
print by clicking File > Print or Cmd + P. A Print dialogue box will pop up where you can select your printing options 
and view a print preview of your Mind Map. 

 

(10.2) Saving 

Remember to save your Mind Map before exiting iMindMap®.  

 On the main toolbar, choose the ‘Save’ icon.   

 If necessary, select the folder in which you want to save the document. 

 Click ‘Save’ 

To Save As, click the drop-down arrow beside the Save icon and select Save As. A  dialogue box will pop 
up where you can choose a location to save your Mind Map. 

Note: All iMindMap documents are automatically saved with the extension ‘.imm’. 

(10.3) Importing 

You can import any FreeMind and MindManager Mind Maps in iMindMap® and amend them. The Import menu is 
located in the Open drop-down menu in the main toolbar. Select which program you are importing from and a 
dialogue box will pop up where you can find the file location of the FreeMind or MindManager Mind Maps. 
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Please note that FreeMind and MindManager Mind Maps must be in XML format in order to be imported to 
iMindMap.  

Speed Mind Map Mode  

We have now created a Mind Map using all the different functions and tools in the standard iMindMap® Mind Map 
Mode.   This is recommended for most tasks as it gives you time to organize your thoughts effectively. However, 
there may be occasions when you want to use iMindMap® for brainstorming so as to capture as many ideas as 
possible in a short space of time. This is when Speed Mind Map Mode should be used.  For example, when working 
with a team you may want to quickly generate a large volume of ideas for later discussion, you could also use this 
mode in the classroom, to record a telephone conversation, for meeting minutes, for group meetings.  

Whereas Mind Mapping Mode has been optimised for organic Mind Mapping, Speed Mind Map Mode is designed 
for speed. 
 
The best way to use Speed Mind Map Mode is to start off your Mind Map using this mode and then complete you 
Mind Map in Mind Map Mode.  This allows you to personalize your map and make it your own.  It is important to 
remember that a Mind Map created by you is much more effective than a Mind Map created for you, so use Mind 
Map Mode whenever possible.  

Using Speed Mind Map Mode and Auto Layout 

 You can select Speed Mind Map Mode by clicking on the button which is located under the 
Mode menu on the toolbar. Once this is switched on, this will allow you to rapidly create a structured Mind Map by 
just using your keyboard. 

 Auto Layout: Once Speed Mind Mapping Mode has been turned on, an Auto Layout dialogue box pops up. 
Auto Layout is a feature in iMindMap that automatically arranges your branches for you. Use the 10-point 
scale to determine how Linear, Organic or Radial you want your Mind Map to look. Accept changes by 
clicking OK. Please note, you cannot bring your Mind Map back to the way it looked in Mind Map mode 
once you have used the Auto Layout tool. 

Even if you are not in Speed Mind Mapping Mode, you can use Auto Layout to arrange your organically 
created Mind Map for you. To Auto Layout your Mind Map, click on the Tools menu on the main Toolbar 
and select Auto Layout. 
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 Once you have accepted the Auto Layout settings, simply click on the red circle button in the centre of 
your central image/idea and start typing. A branch will automatically be drawn to represent your first main 
idea. 

 

 To create an additional main branch, press ‘Enter’ on your keyboard and start typing your next idea. 
Repeat to create more main branches. To select or move around your branches you can use Tab, Shift-Tab, 
the arrow keys on your keyboard or simply click on the new branch. 

 

 To add connecting ideas to one of your main branches, simply start typing while the branch is selected. By 
pressing ‘Enter’ and continuing to type, you can create more child branches (please see Fig 13). 

 

 You can move to a child branch using the arrow keys and continue adding further sub-topics or ideas until 
your brainstorming session is complete. 

 

Fig 13 

 Speed Mind Map Mode intelligently lengthens branches to accommodate longer words that you may type.   
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 Speed Mind Map Mode also automatically reformat your Mind Map when new branches are added, ensuring it 
is well organised. 
 
 Whilst you can manipulate branches in Speed Mind Map mode, this will reduce the ability of the software to 
automatically reformat the structure of your Mind Map.  

 
Note that there are a few functions which have been disabled within Speed Mind Map Mode – these are: Freehand 
Branches; Relationship Branches and all branch manipulation control points.  These will all work fully once you 
switch into Mind Map Mode using the icon button.  

 
To summarise, Speed Mind Map Mode is a brilliant way to start off your Mind Map. Return to Mind Map Mode to 
personalise your Mind Map. It is important to remember that a Mind Map created by you is much more effective 

than a Mind Map created for you, so use Mind Map Mode whenever possible. 
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Mind Map Mode vs. Speed Mind Map Mode 

Here is a summary of the differences between Mind Mapping Mode and Speed Mind Map Mode – it is useful to see 
how, when and why different modes should be used. 

 Mind Map Mode 

 Speed Mind Map Mode 

  
Mind Map Mode 

 
Speed Mind Map Mode 

Type of Mind 
Map 

 
Organic free flowing  

 
More rigid, structured  

 
Recommended 
Uses 

 
Mind Mapping - creative  

 
Brainstorming - fast  

Creative thought, planning, communicating, 
problem solving, memorising, studying, 
summarizing 

Meetings, note taking, group sessions, in the 
classroom, recording a phone conversation 

 
Branches 

 
Organic  

 
Structured  

 
Create your own  

 
Automatically draws them for you 

Manually need to move branches to 
accommodate others 

Automatically moves Speed Mind Mapped 
branches to accommodate others 

Shortens and lengthens branches to fit words Lengthens branches to accommodate long 
words 

 
Benefits 

 
Creative, personalised process 

 
Quick and easy to create 

A Mind Map created by you is much more 
effective that a Mind Map created for you 

As iMindMap structures your Map for you it will 
not be so personalised and therefore 
memorable 

 
Why Use Each 
Mode? 

Mind Map Mode gives you complete control 
over your Mind Map, activating your whole 
brain.  This helps transfer information from 
your short-term to your long-term memory  

If brainstorming, Speed Mind Map Mode is ideal 
as it creates a Mind Map for you.  However, this 
is often not the most effective way to Mind 
Map.  

Enjoy Unleashing the Power of Your Brain! 

 

 
 
 
 

® Buzan’s iMindMap is a registered trademark of Buzan Online Ltd 
© Word and PowerPoint are trademarks of Microsoft Corporation  


